Welcome to the forum, Guest

TOPIC: YACReaderLibraryServer on Gentoo

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3922

jump

Offline

Fresh Boarder

Posts: 5

Karma: 0

I've installed YACReaderLibraryServer 9.0.0 on Gentoo 4.16.11 without problems. Made an init script for start/stop and a cronjob for updating the library. So far the YAC server never crashed uses low memory and cpu time. Only one thing doesn't work. On my iPad 2 iOS 9.3.5 there are no covers visible when I browse the library. I can open the comics and read them. On the server side I don't have any files in .yacreaderlibrary/covers. Is this by design ?
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3923

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

There is an option to disable the covers in the server to speed up the interface when having too many comics, but this shouldn't be enabled by default. Not having any covers at all certainly is weird. How did you create the library?
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3924

jump

Offline

Fresh Boarder

Posts: 5

Karma: 0

I set the following INI entry. But no luck.

[libraryConfig]
REMOTE_BROWSE_PERFORMANCE_WORKAROUND=false

I created the library with YACLibraryServer create-library iComics /mnt/data/Comics/.

I tried the develop version 9.5.0 and changed VERSION="9.0.0". But no luck either.

If I create a library on High Sierra with YACReaderLibrary 9.0.0 with the same location (AFP to /mnt/data/Comics) and browse with my iPad I see the covers. Then i have jpg files in the cover folder on the server.

When I restart the YACLibraryServer on Gentoo with this covers I don't see them on the iPad.

Any ideas ?
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3925

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

Maybe the server doesn't have permission to access these files? Gentoo is a little special as Linux distributions go so I'm not sure.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3926

jump

Offline

Fresh Boarder

Posts: 5

Karma: 0

The server runs with dedicated user/group ID and this user has full read/write access to the library files. While compiling the server I see the following message over and over again:

../../../include/qt5/QtGui/qtgui-config.h:1: warning: "QT_NO_IMAGEFORMAT_JPEG" redefined
#define QT_NO_IMAGEFORMAT_JPEG false

Maybe a hint ?
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3927

jump

Offline

Fresh Boarder

Posts: 5

Karma: 0

Sorry, the message is

../../../include/qt5/QtGui/qtgui-config.h:1: warning: "QT_NO_IMAGEFORMAT_JPEG" redefined
#define QT_NO_IMAGEFORMAT_JPEG true
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 5 months ago #3928

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

I'm strongly starting to suspect that this is a problem with your installation of Qt and that the jpg support is broken. That would explain why the server can serve the raw images contained within the comics, but it can not process the cover images.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 4 months ago #3929

jump

Offline

Fresh Boarder

Posts: 5

Karma: 0

Default USE Flags for qtgui on gentoo are:

dev-qt/qtgui-5.9.4-r3:5/5.9::gentoo USE="gif libinput png udev xcb -accessibility -dbus -debug -egl -eglfs -evdev -gles2 -ibus -jpeg {-test} -tslib -tuio -vnc

changed to:

dev-qt/qtgui-5.9.4-r3:5/5.9::gentoo USE="gif jpeg libinput png udev xcb -accessibility -dbus -debug -egl -eglfs -evdev -gles2 -ibus {-test} -tslib -tuio -vnc

And now the covers are generated in the library and visible on the iPad. I think this is a solved issue. Thanks.
The administrator has disabled public write access.

YACReaderLibraryServer on Gentoo 3 years 4 months ago #3930

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

Glad I could help you. Happy reading!
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
Powered by Kunena Forum