Welcome to the forum, Guest

  • Page:
  • 1
  • 2

TOPIC: Lib no longer working after 9.8.0 - raspberry-pi

Lib no longer working after 9.8.0 - raspberry-pi 4 months 1 week ago #5966

selmf

Offline

Developer

Posts: 603

Thank you received: 130

Karma: 16

Ok, so there is an issue with the comic book archive handling.

There is one thing in your Docker file which strikes me as particularly odd - your install libunarr-dev as a build dependency and you are downloading the unarr source for an embedded build.

Only one of these is needed. Could you try to rebuild YACReader 9.8.0 with only libunarr-dev but not the extra source code? This is the configuration I use on my system and for packaging and for me this works fine.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: dreibona

Lib no longer working after 9.8.0 - raspberry-pi 4 months 1 week ago #5970

dreibona

Offline

Fresh Boarder

Posts: 11

Karma: 0

Only one of these is needed. Could you try to rebuild YACReader 9.8.0 with only libunarr-dev but not the extra source code?
Yep, I tryed a clean install as you asked and works- the install process

My conclusions about the topic (guys I'm totally noob about any of the matter, forgive me if I'm wrong):
- My lib is totally using WEBP inside CBZ files
- This worked up to 9.7.1 headless
- That's why the compiled rpi version didn't find the files, the system can't handle the image format

OK

- Running the rebuild 9.8.0 headless on updated DB
- It can't open files. Server stop running when try to open any CBZ/WEBP
- If I put a new folder with CBZ/WEBP and update server, the folder is not listed, DB completelly ignore the folder
- If the same files are insted CBZ/JPG it worked - navigate, open folder, write to DB
- CBZ/WEBP is dead. Long live CBZ/JPG :cheer:

Luckly I have a backup with only JPG files but it's triple the size with almost the same quality :sick:
The administrator has disabled public write access.

Lib no longer working after 9.8.0 - raspberry-pi 4 months 1 week ago #5971

selmf

Offline

Developer

Posts: 603

Thank you received: 130

Karma: 16

Ah now it makes sense. I think I have an idea what is happening here.

Please do the following:

- double check that the Qt image format plugin for WEBP is installed
- open a bug on our Github (www.github.com/yacreader/yacreader)
- create a small test .cbz with WEBP images and upload it for testing

If this is what I think it is the fix should be very straightforward.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
The following user(s) said Thank You: dreibona

Lib no longer working after 9.8.0 - raspberry-pi 4 months 1 week ago #5972

dreibona

Offline

Fresh Boarder

Posts: 11

Karma: 0

You totally nailed! qt5-imageformats was missing.

By adding qt5-image-formats-plugins (for debian) and libwebp6 in the Dockerfile, now support all image formats.

Should I still open the ticket on Github?
The administrator has disabled public write access.

Lib no longer working after 9.8.0 - raspberry-pi 4 months 1 week ago #5973

selmf

Offline

Developer

Posts: 603

Thank you received: 130

Karma: 16

No, in that case everything is working as it should and there is no bug :) Happy reading!
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Lib no longer working after 9.8.0 - raspberry-pi 4 months 1 week ago #5974

dreibona

Offline

Fresh Boarder

Posts: 11

Karma: 0

Thanks a lot selmf and Luis Ángel!

YAC is the best comic reader ever!

Saludos!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Powered by Kunena Forum