Welcome to the forum, Guest

TOPIC: Change YACReaderLibraryServer port?

Change YACReaderLibraryServer port? 5 years 2 months ago #2487

roosey

Offline

Fresh Boarder

Posts: 3

Karma: 0

How can I change YACReaderLibraryServer port from 8080 to something else?
The administrator has disabled public write access.

Change YACReaderLibraryServer port? 5 years 2 months ago #2488

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

Click the symbol between the cog and the question mark. This opens the server settings menu. There you can set the port.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Change YACReaderLibraryServer port? 5 years 2 months ago #2491

roosey

Offline

Fresh Boarder

Posts: 3

Karma: 0

So I'm running a headless server and sabnzbd is running on 8080 how can I change ports command line?

Thanks
The administrator has disabled public write access.

Change YACReaderLibraryServer port? 5 years 2 months ago #2492

Luis Ángel

Offline

Administrator

Posts: 1822

Thank you received: 389

Karma: 36

It can be set by modifying the settings file: YACReaderLibrary.ini
[listener]
port=9999

Try in this path (I don't remember right now the right path) ~/.config/YACReader/YACReaderLibrary/YACReaderLibrary.ini if the file doesn't exists create it.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.

Change YACReaderLibraryServer port? 5 years 2 months ago #2493

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

On my system it's located in
~/.local/share/YACReader/YACReaderLibrary/
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
Last Edit: 5 years 2 months ago by selmf.
The administrator has disabled public write access.

Change YACReaderLibraryServer port? 4 years 10 months ago #2671

Darkgaber

Offline

Fresh Boarder

Posts: 2

Karma: 0

Hi!
I'm just trying to change the port in my YACReader Server built in a Raspbian Jessie but I don't succeed.
I tried to edit the file but no changes in my library access. Still remains the 8080 port.
I rebooted the Pi but it's always the same.
Any suggestion?
The administrator has disabled public write access.

Change YACReaderLibraryServer port? 4 years 10 months ago #2690

Darkgaber

Offline

Fresh Boarder

Posts: 2

Karma: 0

SOLVED!
In my case, the route I've changed was different from the one you said before:

/root/.local/share/YACReader/YACReaderLibrary/YACReaderLibrary.ini

I use de crontab of ROOT user, not pi user!

Thanks Luis Ángel! :)
Last Edit: 4 years 10 months ago by Darkgaber.
The administrator has disabled public write access.
Powered by Kunena Forum