Welcome to the forum, Guest

  • Page:
  • 1
  • 2

TOPIC: YACReader Library window won’t open on Raspbian

YACReader Library window won’t open on Raspbian 1 year 2 months ago #7457

oblivion328

Offline

Fresh Boarder

Posts: 1

Karma: 0

I’ve been running a comic server on my Raspberry Pi for a while without issue, but I think I broke something when I tried adding one of my existing libraries to the application on another computer. Now it refuses to open a window when launched in the Pi. The process is running, and I can access existing libraries from other devices, but it’s impossible to manage my libraries. I’ve tried reinstalling, but that doesn’t help.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 2 months ago #7460

Luis Ángel

Offline

Administrator

Posts: 2655

Thank you received: 550

Karma: -91

Is the app minimized to the system tray?
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: www.paypal.com/donate?business=5TAMNQCDD...e=Support+YACReader\
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 2 months ago #7492

Abad

Offline

Fresh Boarder

Posts: 5

Karma: 0

Same issue here.
Library on Raspberry, working well. Can read comics of the library in other devices, but no YAC reader window in the pi, so its process is still running.
No app minimized to the system tray.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 2 months ago #7494

Luis Ángel

Offline

Administrator

Posts: 2655

Thank you received: 550

Karma: -91

Are you running yacreaderlibraryserver? I think YACReaderLibrary may detect it running and closes automatically.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: www.paypal.com/donate?business=5TAMNQCDD...e=Support+YACReader\
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 2 months ago #7495

Abad

Offline

Fresh Boarder

Posts: 5

Karma: 0

Yes.
Process “Yacreaderserver start” is running. Try to kill the process, then start YACReader library… but no YACReader windows, and the process is runing again.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 2 months ago #7496

Luis Ángel

Offline

Administrator

Posts: 2655

Thank you received: 550

Karma: -91

That's the problem then. You probably have yacreaderlibraryserver running as a service that starts automatically. YACReaderLibrary runs it's own server, so you can use it instead.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: www.paypal.com/donate?business=5TAMNQCDD...e=Support+YACReader\
Last Edit: 1 year 2 months ago by Luis Ángel.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 1 month ago #7511

Abad

Offline

Fresh Boarder

Posts: 5

Karma: 0

Tryed to kill yacreaderlibraryserver process. Start Yac reader Library, but windows still not working.
Everytime I try to execute YacReader Library, the yacreaderlibraryserver process starts again.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 1 month ago #7512

selmf

Offline

Developer

Posts: 632

Thank you received: 135

Karma: 18

Hi,

I've been getting reports from other users with similar problems. From what I could gather this is caused by a change in how Debian's package format treats systemd services by default. Until recently, you had to explicitely configure a package to enable and start a service, this has changed to all services installed being enabled and started by default.

This means that YACReaderLibraryServer is running on your device and will continue to run unless you disable the service, which means you cannot open the library and window.

The command for disabling a user service is:
systemctl --user stop yacreaderlibraryserver
systemctl --user disable yacreaderlibraryserver

If after doing this you discover that the library window is still not opening, you need to remove the server socket from /tmp. For a bunch of workarounds on how to do this, see this issue:

github.com/YACReader/yacreader/issues/362

Please report back if this resolved your issue.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 4 weeks ago #7534

Abad

Offline

Fresh Boarder

Posts: 5

Karma: 0

Yes, that worked for me.
Just needed to write the two 'systemctl' command.
Tried to reboot the raspberry, and the issue happens again. Writing the command, works again.
The administrator has disabled public write access.

YACReader Library window won’t open on Raspbian 1 year 4 weeks ago #7535

selmf

Offline

Developer

Posts: 632

Thank you received: 135

Karma: 18

I recently updated the YACReader .deb packages to v9.12.0 and split off the headless server into a separate package. Could you update to the newest version and check if the issue still appears?
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Powered by Kunena Forum