Welcome to the forum, Guest

TOPIC: Flatpak version does not support cb7 ?

Flatpak version does not support cb7 ? 1 year 1 month ago #7584

DCLXVI

Offline

Fresh Boarder

Posts: 2

Karma: 0

Hi there,

First of all thanks to the team for the fabulous effort.

I was trying to use the yacreaderlibrary and reader on Fedora 38.

However it seems that the official rpm package does not support 7z, and thus we can't read cb7:
Installed Packages
Name         : yacreader
Version      : 9.12.0
Release      : 1.fc38
Architecture : x86_64
Size         : 5.4 M
Source       : yacreader-9.12.0-1.fc38.src.rpm
Repository   : @System
From repo    : updates
Summary      : Cross platform comic reader and library manager
URL          : https://www.yacreader.com
License      : GPLv3+ and BSD and MIT
Description  : Best comic reader and comic manager with support for .cbr .cbz .zip .rar comic
             : files.

yacreader can't open cb7 and yacreaderlibrary can't either.

I tried the flatpak version, but it's the same problem:
… … … Version        Branch      Arch   Origin  Installation Ref                                                                   Active commit Latest commit Installed size …
… … … 9.12.0.2304234 stable      x86_64 flathub user         com.yacreader.YACReader/x86_64/stable                                 d5ef17afc856  -              11,0 Mo       …

Even though its text states that it can:
• File support: YACReader supports a wide variety of comic files and image types. rar, zip, cbr, cbz, tar, pdf, 7z and cb7, jpeg, gif, png, tiff and bmp.

Plus I'm not sure how to start the library from the flatpak... :huh:

Any suggestion ?
The administrator has disabled public write access.

Flatpak version does not support cb7 ? 1 year 1 month ago #7585

Luis Ángel

Offline

Administrator

Posts: 2670

Thank you received: 550

Karma: -125

The problem is that Linux packages default to unarr. You should try to build from src with 7zip support enabled.
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: www.paypal.com/donate?business=5TAMNQCDD...e=Support+YACReader\
The administrator has disabled public write access.

Flatpak version does not support cb7 ? 1 year 1 month ago #7586

selmf

Offline

Developer

Posts: 636

Thank you received: 135

Karma: 18

The current release of Unarr does not come with 7z support enabled by default. I will look into enabling it for the Flatpak.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Flatpak version does not support cb7 ? 5 months 1 week ago #8102

DCLXVI

Offline

Fresh Boarder

Posts: 2

Karma: 0

Thanks for the replies @selmf @ ,

I tested this today, on Fedora 39, with the flatpak (9.13.1.2307166) and rpm version (yacreader-9.13.1-2.fc39.x86_64)


- for both versions, when inside YacReader and pressing O to open an archive, it doesn't list .cb7 files in a directory (nor .7z).
- for both versions, YACReaderLibrary seems to take into account .cb7 files (and .7z), but they show as 0 pages entries.
- for the flatpak version we can't open any archive (even .cbr, .cbz) from YACReaderLibrary, when double clicking or pressing enter or right-clicking+open, nothing happens, YacReader does not open.
The administrator has disabled public write access.

Flatpak version does not support cb7 ? 5 months 5 days ago #8106

selmf

Offline

Developer

Posts: 636

Thank you received: 135

Karma: 18

We likely need to change the file filter to display 7z and cb7 files for unarr.

The Flatpak has not had the push of the latest unarr which enables 7z by default, so it is still not working. I can't remember if the the interaction between the library and the reader was working when I tested it, but I'll look into it.

The update for the Flatpak is already prepared, but I didn't have time to push it yet. I don't have as much free time to dedicate to YACReader as I used to these days :)
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Flatpak version does not support cb7 ? 5 months 4 days ago #8107

selmf

Offline

Developer

Posts: 636

Thank you received: 135

Karma: 18

I have to correct myself. I *did* push the update for 7z support by default, but I either made a typo in the build script or it does not work for different reasons.

A quick check in the YACReader source revealed that there are a few instances where re-adding cb7 and 7z as supported file format has been forgotten. This leads to symptoms like cb7 and 7z not showing up in the file selection dialog.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.
Powered by Kunena Forum