Welcome to the forum, Guest

TOPIC: qtbase-abi-5-3-2 is not installable Debian stretch

qtbase-abi-5-3-2 is not installable Debian stretch 5 years 2 months ago #2469

orggue

Offline

Fresh Boarder

Posts: 1

Karma: 0

I'm running Debian stretch (debian 9 testing). This is the output of the installation:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 yacreader : Depends: qtbase-abi-5-3-2 but it is not installable
E: Unable to correct problems, you have held broken packages.

qtbase-abi-5-3-2 is no longer available in this version of the os. Is a virtual package which is in libqt5core5a (5.3.2+dfsg-4+deb8u1~bpo70+1). but i have already installed libqt5core5a (5.6.1+dfsg-3 and others). yacreader require qtbase-abi-5-3-2 but i have qtbase-abi-5-6-1.

has anyone a solution to my problem?
The administrator has disabled public write access.

qtbase-abi-5-3-2 is not installable Debian stretch 5 years 2 months ago #2470

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

I'd probably either install the newest version of libqt5core5a from Sid (seems it does provide qtbase-abi-5-3-2) or try doing a forced install which ignores the dependency. Waiting for the fixed package from sid to make it into stretch would also be an option. Or you could try the Ubuntu packages.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

qtbase-abi-5-3-2 is not installable Debian stretch 5 years 2 months ago #2471

Luis Ángel

Offline

Administrator

Posts: 1816

Thank you received: 389

Karma: 36

If everything else fails, you can try to compile YACReader from the sources. The process is similar to this
Contribute to the project becoming a patron: www.patreon.com/yacreader
You can also donate via Pay-Pal: t.ly/ODFV
The administrator has disabled public write access.
Powered by Kunena Forum