Welcome to the forum, Guest

  • Page:
  • 1
  • 2

TOPIC: Server will not import comics w special chacters

Server will not import comics w special chacters 3 years 7 months ago #3723

sl1me.t1me

Offline

Fresh Boarder

Posts: 3

Karma: 0

I recently moved my comics to a linux server running OMV (Debian)
I installed via docker (see forum post).

When updating my library it won't recognize albums or folders with german special characters like "äöüß" in it.
On macOS this never was a problem.

Is there any way to change this behavior?

Many thanks, Timm
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 7 months ago #3725

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

Please run "locale" in a terminal and paste the output here.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 7 months ago #3729

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

I have filed a bug with the provider of the Docker container:

github.com/josetesan/yacreaderlibrary-server-docker/issues/2
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 7 months ago #3736

sl1me.t1me

Offline

Fresh Boarder

Posts: 3

Karma: 0

Thanks for reporting this.
Sorry for replying this late, but I didn't receive a notification on the topic. Have to check my profile, I guess.
I'll try the new container as soon as I can
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 7 months ago #3737

sl1me.t1me

Offline

Fresh Boarder

Posts: 3

Karma: 0

Output of locale:

LANG=de_DE.UTF-8
LANGUAGE=
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 7 months ago #3738

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

The locale looks fine. I have the same on my machine and no problems with special characters in YACReader. The issue is probably the locale in the container or the older version of YACReaderLibraryServer.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 3 months ago #4083

Fabien

Offline

Fresh Boarder

Posts: 6

Karma: 0

Hello,

I'm running YWCReaderserver on a QNAP container and currently facing the same issue. Running "locale" in the container terminal give me the following result :

LANG=
LANGUAGE=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

I've tried to change it, but I was not successful (my knowledge using containers is too limited for now). Any help to fix it will be higly appreciated.

Regards,
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 3 months ago #4084

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

I reported this to the author of the docker container, but I don't think he got it working. I'm currently busy preparing the .deb and .rpm packages for YACReader 9.5.0, but once that is done I will have another look at the problem. Maybe we can work something out.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 3 months ago #4087

Fabien

Offline

Fresh Boarder

Posts: 6

Karma: 0

Thanks a lot for your very prompt reply ! Looking forward...

I will be further looking on my side too. Should i be able to find a fix, I'll post it here.

Regards,
The administrator has disabled public write access.

Server will not import comics w special chacters 3 years 3 months ago #4109

selmf

Offline

Developer

Posts: 604

Thank you received: 130

Karma: 17

Here's a workaround:
$ docker exec -it yacserver /bin/bash
$ export LC_ALL=C.UTF8
$ YACReaderLibraryServer update-library /comics
$ exit

After this all comics should be available in the library. If this works for you I will get in touch with josetsan/muallin to enable it by default.
My answers are not necessarily official YACReader statements but mostly represent my own opinion in technical matters.
Last Edit: 3 years 3 months ago by selmf.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Powered by Kunena Forum